tinc: Recipe for 1.0.9
[openembedded/mini2440.git] / recipes / quake / quetoo_0.6.1.bb
blob33a707579985a146201c90b30aa402917c5292c5
1 DESCRIPTION = "Initially a fork of the Quake2Forge project, this engine aims to provide security and performance enhancements."
2 LICENSE = "GPLv2"
4 DEPENDS = "libsdl-x11 zlib mesa"
5 SRC_URI = "http://tastyspleen.net/~jdolan/quetoo-${PV}.tar.bz2"
7 inherit autotools pkgconfig
10 EXTRA_OECONF = "\
11 --with-games=baseq2 \
12 --with-sdl \
13 --with-zlib \
16 do_configure() {
17 for i in ctf qmass vanctf ; do
18 mkdir -p ${S}/data/$i/sound
19 mkdir -p ${S}/data/$i/maps
20 mkdir -p ${S}/src/$i
21 touch ${S}/data/$i/Makefile.in
22 touch ${S}/data/$i/sound/Makefile.in
23 touch ${S}/data/$i/maps/Makefile.in
24 touch ${S}/src/$i/Makefile.in
25 done
27 sed -i -e s:-Werror::g ${S}/configure
28 gnu-configize --force
29 oe_runconf
30 rm config.log
33 do_install_append() {
34 mv ${D}${bindir}/${TARGET_PREFIX}quetoo ${D}${bindir}/quetoo
37 FILES_${PN}-dbg += "${libdir}/quetoo/baseq2/.debug"