tinc: Recipe for 1.0.9
[openembedded/mini2440.git] / recipes / frotz / frotz_2.42.bb
blob8daa6c514e71d64ffa452273fdefa0350aa3fa77
1 LICENSE = "GPL"
2 DESCRIPTION = "Frotz is an interpreter for Infocom games and other Z-machine games."
3 HOMEPAGE = "http://www.cs.csubak.edu/~dgriffi/proj/frotz/"
4 SECTION = "console/games"
5 DEPENDS = "ncurses"
7 SRC_URI = "http://www.cs.csubak.edu/~dgriffi/proj/frotz/files/frotz-${PV}.tar.gz \
8 file://Makefile.patch;patch=1 "
10 do_configure() {
11 patch -N ${s}/ux_init.c < remove_root_restriction.patch || :
12 rm -f ${SourceTree}/frotz.conf
15 EXTRA_OEMAKE = "CC='${CC}' INCL='${CFLAGS}' LIB='${LDFLAGS}' PREFIX=${prefix} CONFIG_DIR=${sysconfdir}"
17 do_compile() {
18 oe_runmake frotz
19 sed 's/^[a-z]/#&/' frotz.conf-big > frotz.conf;
22 do_install() {
23 oe_runmake PREFIX=${D}${prefix} MAN_PREFIX=${D}${mandir} install