tinc: Recipe for 1.0.9
[openembedded/mini2440.git] / recipes / apr / apr-util_1.3.4.bb
blob6b2e9cc9038de10ff0cca15853d2dc3388743256
1 DESCRIPTION = "Apache Portable Runtime (APR) companion library"
2 SECTION = "libs"
3 DEPENDS = "apr expat gdbm"
4 LICENSE = "Apache License, Version 2.0"
6 PR = "r5"
8 SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.gz \
9 file://configfix.patch;patch=1 \
10 file://configure_fixes.patch;patch=1"
12 EXTRA_OECONF = "--with-apr=${STAGING_BINDIR_CROSS}/apr-1-config \
13 --with-dbm=gdbm \
14 --with-gdbm=${STAGING_DIR_HOST}${layout_prefix} \
15 --without-sqlite2 \
16 --without-sqlite3 \
17 --with-expat=${STAGING_DIR_HOST}${layout_prefix}"
20 inherit autotools_stage lib_package binconfig
22 OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
24 do_configure_prepend() {
25 cp ${STAGING_DATADIR}/apr/apr_rules.mk ${S}/build/rules.mk
26 echo "AC_PROG_LIBTOOL" >> ${S}/configure.in
29 do_configure_append() {
30 sed -i -e s:apr_builders=/usr/share/build-1:apr_builders=${STAGING_DATADIR}/build-1:g ${S}/build/rules.mk
31 sed -i /^LIBTOOL/d ${S}/build/rules.mk
32 echo LIBTOOL="${STAGING_BINDIR_NATIVE}/${TARGET_PREFIX}libtool --tag=CC" >> ${S}/build/rules.mk