tinc: Recipe for 1.0.9
[openembedded/mini2440.git] / recipes / apr / apr-util_1.2.7.bb
blob5f019d624e804f4a91b201070d5244cbafc2c2a4
1 DESCRIPTION = "Apache Portable Runtime (APR) companion library"
2 SECTION = "libs"
3 DEPENDS = "apr expat gdbm"
4 LICENSE = "Apache License, Version 2.0"
6 PR = "r3"
8 # apache mirrors?
9 SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.gz \
10 file://configure_fixes.patch;patch=1"
12 EXTRA_OECONF = "--with-apr=${STAGING_BINDIR_CROSS} --with-dbm=gdbm \
13 --with-gdbm=${STAGING_DIR_HOST}${layout_prefix} \
14 --without-sqlite2 \
15 --without-sqlite3 \
16 --with-expat=${STAGING_DIR_HOST}${layout_prefix}"
19 inherit autotools lib_package binconfig
21 OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
23 do_configure_prepend () {
24 cp ${STAGING_DATADIR}/apr/apr_rules.mk ${S}/build/rules.mk
27 do_stage() {
28 autotools_stage_all