tinc: Recipe for 1.0.9
[openembedded/mini2440.git] / recipes / apr / apr-util_1.2.12.bb
blob6613ab99a8a32f9dcd31a7e33252249992a231e2
1 DESCRIPTION = "Apache Portable Runtime (APR) companion library"
2 SECTION = "libs"
3 DEPENDS = "apr expat gdbm"
4 LICENSE = "Apache License, Version 2.0"
6 PR = "r3"
8 inherit autotools lib_package binconfig
10 # apache mirrors?
11 SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.gz \
12 file://configure_fixes.patch;patch=1"
14 EXTRA_OECONF = "--with-apr=${STAGING_BINDIR_CROSS} --with-dbm=gdbm \
15 --with-gdbm=${STAGING_DIR_HOST}${layout_prefix} \
16 --without-sqlite2 \
17 --without-sqlite3 \
18 --with-expat=${STAGING_DIR_HOST}${layout_prefix}"
21 OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
22 EXTRA_OEMAKE = " LIBTOOL=\"${S}/${TARGET_PREFIX}libtool\" "
24 export LIBTOOL="${S}/${TARGET_PREFIX}libtool"
26 do_configure_prepend() {
27 cp ${STAGING_BINDIR_NATIVE}/${TARGET_PREFIX}libtool ${S}/
28 cp ${STAGING_DATADIR}/apr/apr_rules.mk ${S}/build/rules.mk
29 echo "AC_PROG_LIBTOOL" >> ${S}/configure.in
30 libtoolize --force
33 do_stage() {
34 autotools_stage_all