help2man: fix drag in of target perl for the native package
[openembedded.git] / recipes / help2man / help2man_1.38.2.bb
blobab06186d61e6499564b560d989c99c87d06e5a05
1 DESCRIPTION = "Program to create simple man pages"
2 SECTION = "devel"
3 LICENSE = "GPLv3"
4 DEPENDS = "gettext-native perl-native liblocale-gettext-perl-native"
5 DEPENDS_virtclass-native = "perl-native autoconf-native automake-native"
6 RDEPENDS_${PN} = "gettext perl liblocale-gettext-perl"
7 RDEPENDS_${PN}_virtclass-native = ""
8 PR = "r2"
10 SRC_URI = "${GNU_MIRROR}/${BPN}/${BPN}-${PV}.tar.gz"
12 SRC_URI[md5sum] = "426671c6fe79e5ef2233303367eab5a6"
13 SRC_URI[sha256sum] = "952c29561bce8b233aa10af7f0e0c79c8243712810bf8ddf01e6efd82ce250d1"
15 inherit autotools
17 EXTRA_OECONF = "--disable-nls"
19 BBCLASSEXTEND = "native"
21 # We don't want to reconfigure things
22 do_configure() {
23 oe_runconf
26 do_install_append () {
27 # Make sure we use /usr/bin/env perl
28 sed -i -e "1s:#!.*:#! /usr/bin/env perl:" ${D}${bindir}/help2man