dbus-hlid: bump
[openembedded.git] / recipes / freesmartphone / frameworkd_git.bb
blob76d83f47b422519df2f802e7a212c926743e9c92
1 DESCRIPTION = "The reference implementation of the freesmartphone.org framework APIs"
2 HOMEPAGE = "http://www.freesmartphone.org"
3 AUTHOR = "FreeSmartphone.Org Development Team"
4 SECTION = "console/network"
5 DEPENDS = "python-cython-native python-pyrex-native"
6 LICENSE = "GPL"
7 SRCREV = "e31fa77906981a56be2271246693fd929c973abf"
8 PV = "0.9.5.9+gitr${SRCPV}"
9 PR = "r11"
10 PE = "1"
12 inherit distutils update-rc.d python-dir
14 INITSCRIPT_NAME = "frameworkd"
15 INITSCRIPT_PARAMS = "defaults 29"
17 SRC_URI = "${FREESMARTPHONE_GIT}/framework.git;protocol=git;branch=master \
18 file://oeventsd-use-opimd-signals.patch \
19 file://0001-oeventsd-workaround-buggy-kernel-to-get-full-vibrati.patch \
22 S = "${WORKDIR}/git"
24 do_configure_append() {
25 echo "version=\"${PV}\"" >framework/__version__.py
28 do_install_append() {
29 frameworkd_install_machine_specific_configs
32 # machines with enabled ogsmd
33 do_install_append_a780() {
34 frameworkd_install_ogsmd_configs
36 do_install_append_eten-m800() {
37 frameworkd_install_ogsmd_configs
40 frameworkd_install_ogsmd_configs() {
41 # Install machine specific files
42 install -d ${D}${sysconfdir}/freesmartphone/ogsmd
43 install -m 0644 ${S}/etc/freesmartphone/ogsmd/cell.db ${D}${sysconfdir}/freesmartphone/ogsmd
44 install -m 0644 ${S}/etc/freesmartphone/ogsmd/la.db ${D}${sysconfdir}/freesmartphone/ogsmd
45 install -m 0644 ${S}/etc/freesmartphone/ogsmd/networks.tab ${D}${sysconfdir}/freesmartphone/ogsmd
47 frameworkd_install_machine_specific_configs() {
48 # Fix permissions
49 chmod 755 ${D}${sysconfdir}/init.d/frameworkd
50 # Check for machine specific conf.
51 CONF_PATH="${S}/etc"
52 CONF_PATH_MACHINE="${CONF_PATH}"
53 if [ -d "${CONF_PATH}/${MACHINE}" ] ; then
54 CONF_PATH_MACHINE="${CONF_PATH}/${MACHINE}"
56 # Install machine specific files
57 install -m 0644 ${CONF_PATH_MACHINE}/frameworkd.conf ${D}${sysconfdir}
59 # Check for machine specific conf.
60 CONF_PATH="${S}/etc/freesmartphone/oevents"
61 CONF_PATH_MACHINE="${CONF_PATH}"
62 if [ -d "${CONF_PATH}/${MACHINE}" ] ; then
63 CONF_PATH_MACHINE="${CONF_PATH}/${MACHINE}"
65 install -m 0644 ${CONF_PATH_MACHINE}/rules.yaml ${D}${sysconfdir}/freesmartphone/oevents/
68 RDEPENDS_${PN} += "\
69 fsousaged \
72 RDEPENDS_${PN} += "\
73 python-ctypes \
74 python-dbus \
75 python-datetime \
76 python-difflib \
77 python-logging \
78 python-pprint \
79 python-pyalsaaudio \
80 python-pygobject \
81 python-pyrtc \
82 python-pyserial \
83 python-pyyaml \
84 python-shell \
85 python-subprocess \
86 python-syslog \
87 python-textutils \
88 python-multiprocessing \
89 ${PN}-config \
92 RRECOMMENDS_${PN} += "\
93 alsa-utils-amixer \
94 python-gst \
95 python-phoneutils \
96 python-vobject \
97 ppp \
100 PACKAGES =+ "${PN}-config"
101 PACKAGE_ARCH_${PN}-config = "${MACHINE_ARCH}"
103 # - add wmiconfig for wireless configuration
104 RDEPENDS_${PN}-config = "fso-sounds"
105 RDEPENDS_${PN}-config_append_om-gta02 = " wmiconfig"
106 RREPLACES_${PN}-config = "frameworkd-config-shr"
107 RCONFLICTS_${PN}-config = "frameworkd-config-shr"
109 FILES_${PN}-config = "\
110 ${sysconfdir}/frameworkd.conf \
111 ${sysconfdir}/freesmartphone \
113 CONFFILES_${PN}-config = "\
114 ${sysconfdir}/frameworkd.conf \
115 ${sysconfdir}/freesmartphone/opreferences/conf/phone/silent.yaml \
116 ${sysconfdir}/freesmartphone/opreferences/conf/phone/default.yaml \
117 ${sysconfdir}/freesmartphone/opreferences/conf/phone/vibrate.yaml \
118 ${sysconfdir}/freesmartphone/opreferences/conf/phone/ring.yaml \
119 ${sysconfdir}/freesmartphone/opreferences/conf/profiles/default.yaml \
120 ${sysconfdir}/freesmartphone/opreferences/conf/rules/silent.yaml \
121 ${sysconfdir}/freesmartphone/opreferences/conf/rules/default.yaml \
122 ${sysconfdir}/freesmartphone/opreferences/conf/rules/vibrate.yaml \
123 ${sysconfdir}/freesmartphone/opreferences/conf/rules/ring.yaml \
124 ${sysconfdir}/freesmartphone/oevents/rules.yaml \
127 PACKAGE_ARCH_${PN} = "${BASE_PACKAGE_ARCH}"
128 FILES_${PN} += "${sysconfdir}/dbus-1 ${sysconfdir}/freesmartphone ${sysconfdir}/init.d ${datadir}"
129 FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/framework/subsystems/*/.debug"
131 #EXPORT_FUNCTIONS install_machine_specific_configs install_ogsmd_configs