dbus-hlid: bump
[openembedded.git] / classes / cml1.bbclass
blobd3d49ebdf9e6e6a7a915017f177cf1ece05d5bef
1 cml1_do_configure() {
2         set -e
3         unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
4         oe_runmake oldconfig
7 do_menuconfig() {
8         export termwindowtitle="${pn} kernel configuration"
9         export shellcmds="make menuconfig"
10         ${termcmdrun}
11         if [ $? -ne 0 ]; then
12                 echo "fatal: '${termcmd}' not found. check termcmd variable."
13                 exit 1
14         fi
17 do_menuconfig[nostamp] = "1"
18 addtask menuconfig after do_configure
19 EXPORT_FUNCTIONS do_configure
20 addtask configure after do_unpack do_patch before do_compile