fsoaudiod: add asound.conf to CONFFILES and RCONFLICTS with alsa-state
[openembedded.git] / recipes / freesmartphone / fsoaudiod_git.bb
blob7205f796373b8637aa26471eff04f402884f1866
1 require cornucopia.inc
2 inherit fso-plugin
4 DEPENDS += "alsa-lib"
6 # We need to uncomment the line below after the migration of all scenario files from
7 # fsodeviced to fsoaudiod is done. Otherwise we will get build errors as both fsodeviced
8 # and fsoaudiod are dependencies of the FSO framework.
9 # PROVIDES_${PN} = "openmoko-alsa-scenarios virtual/alsa-scenarios"
11 SRCREV = "${FSO_CORNUCOPIA_SRCREV}"
12 PV = "0.1.0+gitr${SRCPV}"
13 PE = "2"
14 PR = "${INC_PR}.2"
16 inherit update-rc.d
18 INITSCRIPT_NAME = "fsoaudiod"
19 INITSCRIPT_PARAMS = "defaults 30"
21 SRC_URI += "file://fsoaudiod"
23 CONFFILES_${PN} = " \
24 ${sysconfdir}/freesmartphone/conf/palm_pre/fsoaudiod.conf \
25 ${sysconfdir}/asound.conf \
27 RCONFLICTS_${PN} = "alsa-state"
29 do_install_append() {
30 install -d ${D}${sysconfdir}/init.d/
31 install -m 0755 ${WORKDIR}/fsoaudiod ${D}${sysconfdir}/init.d/