angstrom: prefer the git version of tslib
[openembedded.git] / classes / typecheck.bbclass
blobbacaad8691c414a98c39ba92800281a3ba972e87
1 # Check types of bitbake configuration variables
3 # See oe.types for details.
5 python check_types() {
6     if isinstance(e, bb.event.ConfigParsed):
7         for key in e.data.keys():
8             if e.data.getVarFlag(key, "type"):
9                 oe.data.typed_value(key, e.data)
11 addhandler check_types