angstrom: prefer the git version of tslib
[openembedded.git] / classes / scratchbox-compat.bbclass
blob6cf92bde5d9974b980d0c02601521c0a2eb60338
1 # By adding this class to your build all binaries get the special rpath
2 # "/scratchbox/host_shared/lib/:/scratchbox/tools/lib/"
3 # Doing so makes libraries and programs runnable inside the Scratchbox
4 # environment as native binaries (not for the CPU that Scratchbox is
5 # emulating).
7 do_configure_prepend () {
8   export LD_RUN_PATH="/scratchbox/host_shared/lib:/scratchbox/tools/lib"
11 do_compile_prepend () {
12   export LD_RUN_PATH="/scratchbox/host_shared/lib:/scratchbox/tools/lib"