angstrom: prefer the git version of tslib
[openembedded.git] / classes / qemu.bbclass
blob66dfb2b0d21b1865e4bcdba4a9c2b6cc7be1947d
2 # This class contains functions for recipes that need QEMU or test for its
3 # existance.
6 def qemu_target_binary(data):
7         import bb
9         target_arch = bb.data.getVar("TARGET_ARCH", data, 1)
10         if target_arch in ("i486", "i586", "i686"):
11                 target_arch = "i386"
12         elif target_arch == "powerpc":
13                 target_arch = "ppc"
15         return "qemu-" + target_arch