angstrom: prefer the git version of tslib
[openembedded.git] / classes / pkgconfig.bbclass
blobd96b708c97eae56495db33a9cdda24b0a1173a4a
1 DEPENDS_prepend = "pkgconfig-native "
3 do_install_prepend () {
4         for i in `find ${S}/ -name "*.pc" -type f` ; do \
5                 sed -i -e 's:-L${STAGING_LIBDIR}::g' \
6                         -e 's:-R${STAGING_LIBDIR}::g' \
7                         -e 's:-I${STAGING_INCDIR}::g' \
8                         -e 's:-isystem${STAGING_INCDIR}::g' \
9                         $i
10         done
13 SYSROOT_PREPROCESS_FUNCS += "pkgconfig_sysroot_preprocess"
15 pkgconfig_sysroot_preprocess () {
16         install -d ${SYSROOT_DESTDIR}${PKG_CONFIG_DIR}
17         for pc in `find ${S} -name '*.pc' -type f | grep -v -- '-uninstalled.pc$'`; do
18                 pcname=`basename $pc`
19                 if [ ! -f ${SYSROOT_DESTDIR}${PKG_CONFIG_DIR}/$pcname ]; then
20                         oenote "$pcname was not installed."
21                 fi
22         done