angstrom: prefer the git version of tslib
[openembedded.git] / classes / efl.bbclass
blob2dc6fc2097d6f4c35b566d0b0bb9247878d43a03
1 SECTION = "e/libs"
2 LICENSE = "MIT BSD"
3 DEPENDS += "pkgconfig-native"
5 # revision 0d93ec84b30bc1bee2caaee72d667f87bc468a70 made SRCDATE and hence PV go backwards, so we need to up PE to unbreak builds and feeds :(
6 PE = "2"
8 inherit e-base autotools
10 # evas-native looks at this var, so keep it
12 do_configure_prepend() {
13         autopoint || touch config.rpath
16 do_install_prepend () {
17         for i in `find ${S}/ -name "*.pc" -type f` ; do \
18                 sed -i -e 's:-L${STAGING_LIBDIR}::g' -e 's:-I${STAGING_INCDIR}::g' $i
19         done
22 # This construction is stupid, someone with more E knowledge should change it to =+ or something
23 PACKAGES = "${PN}-dbg ${PN} ${PN}-themes ${PN}-dev ${PN}-doc ${PN}-tests ${PN}-static"
25 FILES_${PN} = "${libdir}/*.so.* \
26                ${libdir}/edje/modules/${PN}/*/module.so \
27                ${libdir}/${PN}/plugins/*.so \
28                ${datadir}/dbus-1/services/* \
32 FILES_${PN}-themes = "${datadir}/${PN}/themes \
33                       ${datadir}/${PN}/data \
34                       ${libdir}/${PN}/plugins/data/*.edj \
35                       ${datadir}/${PN}/fonts \
36                       ${datadir}/${PN}/pointers \
37                       ${datadir}/${PN}/images \
38                       ${datadir}/${PN}/users \
39                       ${datadir}/${PN}/images \
40                       ${datadir}/${PN}/styles"
42 FILES_${PN}-dev   += "${bindir}/${PN}-config \
43                       ${libdir}/pkgconfig/* \
44                       ${libdir}/lib*.la \
45                       ${libdir}/*.so \
46                       ${libdir}/${PN}/*.la \
47                       ${libdir}/${PN}/*/*.la \
48                       ${datadir}/${PN}/edje_externals \
49                       ${libdir}/edje/modules/${PN}/*/module.la \
52 FILES_${PN}-static += "${libdir}/${PN}/*.a \
53                        ${libdir}/${PN}/*/*.a \
56 FILES_${PN}-dbg +=   "${libdir}/${PN}/.debug \
57                       ${libdir}/${PN}/*/.debug \
58                       ${libdir}/edje/modules/${PN}/*/.debug/module.so \
61 FILES_${PN}-tests  = "${bindir}/${PN} \
62                       ${bindir}/*_* \
63                       ${datadir}"