angstrom: prefer the git version of tslib
[openembedded.git] / classes / e.bbclass
blob88a1f6a3605648a3b088bb51c9664295bd4c574d
1 SECTION = "e/apps"
3 inherit e-base autotools pkgconfig binconfig
5 do_prepsources () {
6         make clean distclean || true
8 addtask prepsources after do_patch before do_configure
10 do_configure_prepend() {
11         autopoint || touch config.rpath
14 do_configure_append() {
15         find ${S} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
18 export CURL_CONFIG = "${STAGING_BINDIR_CROSS}/curl-config"
19 export FREETYPE_CONFIG = "${STAGING_BINDIR_CROSS}/freetype-config"
21 # This construction is stupid, someone with more E knowledge should change it to =+ or something
22 # And it's in efl.bbclass as well....
23 PACKAGES = "${PN}-dbg ${PN}-themes ${PN} ${PN}-dev ${PN}-doc ${PN}-lib ${PN}-static"
24 FILES_${PN}-lib = "${libdir}/lib*.so.*"
25 FILES_${PN}-themes = "${datadir}/${PN}/themes ${datadir}/${PN}/data ${datadir}/${PN}/fonts ${datadir}/${PN}/pointers ${datadir}/${PN}/images ${datadir}/${PN}/users ${datadir}/${PN}/images ${datadir}/${PN}/styles"
26 FILES_${PN}-dev += "${includedir} ${libdir}/lib*.so"