angstrom: prefer the git version of tslib
[openembedded.git] / classes / dietlibc.bbclass
blob2676385197d896768037f3e924ee2a78d364ea71
1 DEPENDS =+ "dietlibc"
3 def dietlibc_after_parse(d):
4     import bb
5     # Remove the NLS
6     cfg = oe_filter_out('--(dis|en)able-nls', bb.data.getVar('EXTRA_OECONF', d, 1) or "", d)
7     # Remove shared enable static only
8     cfg += " --disable-nls --disable-shared --enable-static"
9     bb.data.setVar('EXTRA_OECONF', cfg, d)
10     cfg = bb.data.getVar('EXTRA_OEMAKE', d, 1) or ""
11     cfg = oe_filter_out("\'CC=", bb.data.getVar('EXTRA_OEMAKE', d, 1) or "", d)
12     cfgtmp = "\'CC=\"diet ${CCACHE}\""
13     cfgtmp += cfg
14     bb.data.setVar('EXTRA_OEMAKE', cfgtmp, d)
16 #python () {
17 #    dietlibc_after_parse(d)
20 set_dietlibc_env () {
21         export CC="diet ${CC}"
24 do_compile_prepend() {
25     set_dietlibc_env
28 do_configure_prepend() {
29     set_dietlibc_env