angstrom: prefer the git version of tslib
[openembedded.git] / classes / angstrom-blacklist.bbclass
blobf1146edd8251c669c611b141b02fd54a6ee60abd
1 # anonymous support class for angstrom
2
3 # Features:
5 # * blacklist handling, set ANGSTROM_BLACKLIST_pn-blah = "message"
8 python () {
9     import bb
11     blacklist = bb.data.getVar("ANGSTROM_BLACKLIST", d, 1)
12     pkgnm = bb.data.getVar("PN", d, 1)
13     distro = bb.data.getVar("DISTRO", d, 1)
15     if blacklist:
16         bb.note("%s DOES NOT support %s because %s" % (distro,pkgnm, blacklist))
17         raise bb.parse.SkipPackage("%s DOES NOT support %s because %s" % (distro,pkgnm, blacklist))