beagleboard-test-scripts: BeagleBoard userbutton detection for flashing
[openembedded.git] / recipes / beagleboard / beagleboard-test-scripts_git.bb
blobbb0e6e4e5f02cc0fa0a93c7084a5d574fcf1ae40
1 ## Reminder: The correct spacing for a variable is FOO = "BAR" in : PR="r1"
2 DESCRIPTION = "BeagleBoard test scripts"
3 HOMEPAGE = "http://beagleboad.org/support"
4 PR = "r4"
6 SRC_URI = "git://gitorious.org/~joelf/beagleboard-validation/validation-scripts.git;protocol=git \
9 SRCREV = "f7ba1b49190003af524f1a768ec887955a9994a0"
10 S = "${WORKDIR}/git"
12 inherit update-rc.d
13 INITSCRIPT_NAME = "flash-nand-fs.sh"
14 INITSCRIPT_PARAMS = "start 99 2 3 4 5 ."
16 do_compile() {
17 ${CC} -o userbutton-pressed ${CFLAGS} ${LDFLAGS} flashing/userbutton-pressed.c
20 do_install() {
21 TEST_FILES=" \
22 testaudio \
23 testcamera \
24 testdsp \
25 testedid \
26 testled \
27 testmem \
28 testneon \
29 testsvideo \
30 testuserbtn \
31 editbootscr \
32 edituserscr \
33 readgpio \
35 install -d ${D}/${bindir}
36 for i in ${TEST_FILES}; do
37 install -m 0755 ${S}/${i} ${D}/${bindir}
38 done
39 # A script to flash NAND if the board has it, and if there is valid image to flash on the SD Card.
40 # We also register it as an init script so that the SD Card auto-flashes to NAND during boot.
41 install -d ${D}/${sysconfdir}/init.d/
42 install -m 0755 ${S}/flashing/flash-nand-fs.sh ${D}/${sysconfdir}/init.d/flash-nand-fs.sh
43 install -m 0755 userbutton-pressed ${D}/${bindir}/userbutton-pressed
44 install -d ${D}/boot/
45 install -m 0755 ${S}/flashing/user.txt ${D}/boot/user.txt
46 install -m 0755 ${S}/flashing/uEnv.txt ${D}/boot/uEnv.txt