www-client/netsurf: kill old patch, take it to /etc/portage/patches if you want to...
[netsurf-overlay.git] / dev-util / netsurf-buildsystem / netsurf-buildsystem-9999.ebuild
blobc981a05da91bf3bc259c87b2f9106a1e64d18ac3
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=5
6 NETSURF_BUILDSYSTEM="buildsystem-9999"
8 inherit git-r3
10 DESCRIPTION="Netsurf buildsystem"
11 HOMEPAGE="http://www.netsurf-browser.org/"
12 EGIT_REPO_URI="http://git.netsurf-browser.org/buildsystem.git"
13 SRC_URI=""
15 LICENSE="MIT"
16 SLOT="0"
17 KEYWORDS="~x86 ~amd64"
18 IUSE=""
20 DEPEND=""
22 DOCS=( README )
24 src_compile() {
28 src_install() {
29 dodir /usr/share/netsurf-buildsystem/
30 cp -R "${S}/citools" "${D}/usr/share/netsurf-buildsystem/"
31 cp -R "${S}/example" "${D}/usr/share/netsurf-buildsystem/"
32 cp -R "${S}/llvm" "${D}/usr/share/netsurf-buildsystem/"
33 cp -R "${S}/Makefile" "${D}/usr/share/netsurf-buildsystem/"
34 cp -R "${S}/makefiles" "${D}/usr/share/netsurf-buildsystem/"
35 cp -R "${S}/testtools" "${D}/usr/share/netsurf-buildsystem/"