scripts: moved important shell / perl scripts to scripts/ instead of contrib
[netsniff-ng.git] / contrib / debian / rules
bloba1e643c272b51e8d19340a6788b44dcbb574f9ed
1 #!/usr/bin/make -f
3 # debian/rules for netsniff-ng
4 # by Daniel Borkmann
6 # Uncomment this to turn on verbose mode.
7 #export DH_VERBOSE=1
9 build: build-stamp
10 build-stamp:
11 dh_testdir
12 cd src; $(MAKE) DESTDIR=$(CURDIR)/debian/netsniff-ng all
13 touch $@
15 clean:
16 dh_testdir
17 dh_testroot
18 rm -f build-stamp
19 cd src; $(MAKE) clean
20 dh_clean
22 install: build
23 dh_testdir
24 dh_testroot
25 dh_prep
26 dh_installdirs
27 cd src; $(MAKE) install DESTDIR=$(CURDIR)/debian/netsniff-ng
29 # Build architecture-independent files here.
30 binary-indep: build install
31 # We have nothing to do by default.
33 # Build architecture-dependent files here.
34 binary-arch: build install
35 dh_testdir
36 dh_testroot
37 dh_installdocs
38 dh_installexamples
39 dh_installchangelogs
40 dh_strip
41 dh_compress
42 dh_fixperms
43 dh_installdeb
44 dh_shlibdeps
45 dh_gencontrol
46 dh_md5sums
47 dh_builddeb
49 binary: binary-arch binary-indep
50 .PHONY: build clean binary-indep binary-arch binary install