Provide some markup shortcuts for the <include> tag.
[muse-el.git] / debian / rules
blob762b59c877e0e6a53d6a2bf006aeb05736b63ef8
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
5 # Uncomment this to turn on verbose mode.
6 #export DH_VERBOSE=1
7 LANG=C
8 LC_CTYPE=C
10 PACKAGE = muse-el
11 PKGDIR = debian/${PACKAGE}
12 DOCDIR = /usr/share/doc/${PACKAGE}
13 LISPDIR = /usr/share/emacs/site-lisp/${PACKAGE}
15 configure: configure-stamp
16 configure-stamp:
17 dh_testdir
18 # Add here commands to configure the package.
20 touch configure-stamp
22 build: configure-stamp build-stamp
23 build-stamp:
24 dh_testdir
25 makeinfo muse.texi
26 makeinfo --html --output=html muse.texi
27 # Add here commands to compile the package.
28 $(MAKE) autoloads
29 $(MAKE) examples
30 #/usr/bin/docbook-to-man debian/muse.sgml > muse.1
32 touch build-stamp
34 clean:
35 dh_testdir
36 dh_testroot
37 rm -f build-stamp configure-stamp
38 # Add here commands to clean up after the build process.
39 -$(MAKE) realclean
41 dh_clean
43 install: build
44 dh_testdir
45 dh_testroot
46 dh_clean -k
47 dh_installdirs
49 # Add here commands to install the package into debian/muse.
50 # $(MAKE) install DESTDIR=$(CURDIR)/debian/muse
51 install -m 644 lisp/*.el $(PKGDIR)$(LISPDIR)
52 install -m 644 experimental/*.el $(PKGDIR)$(LISPDIR)/experimental
53 install -m 644 contrib/*.el $(PKGDIR)$(LISPDIR)/contrib
54 install -m 644 contrib/pyblosxom/*.py $(PKGDIR)$(DOCDIR)/contrib/pyblosxom
56 # Other documentation
57 install -m 0644 AUTHORS ${PKGDIR}${DOCDIR}/AUTHORS
58 install -m 0644 NEWS ${PKGDIR}${DOCDIR}/NEWS
59 install -m 0644 README ${PKGDIR}${DOCDIR}/README
60 install -m 0644 ChangeLog ${PKGDIR}${DOCDIR}/changelog
61 cat ChangeLog.2005 >> ${PKGDIR}${DOCDIR}/changelog
62 cat ChangeLog.2004 >> ${PKGDIR}${DOCDIR}/changelog
64 # Build architecture-independent files here.
65 binary-indep: build install
66 # We have nothing to do by default.
68 # Build architecture-dependent files here.
69 binary-arch: build install
70 dh_testdir
71 dh_testroot
72 # dh_installdebconf
73 dh_installdocs
74 dh_installexamples
75 # dh_installmenu
76 # dh_installlogrotate
77 dh_installemacsen
78 # dh_installpam
79 # dh_installmime
80 # dh_installinit
81 # dh_installcron
82 # dh_installman
83 dh_installinfo
84 # dh_undocumented
85 dh_installchangelogs
86 dh_link
87 dh_strip
88 dh_compress
89 dh_fixperms
90 # dh_makeshlibs
91 dh_installdeb
92 # dh_perl
93 # dh_shlibdeps
94 dh_gencontrol
95 dh_md5sums
96 dh_builddeb
98 binary: binary-indep binary-arch
99 .PHONY: build clean binary-indep binary-arch binary install configure