Merged from mwolson@gnu.org--2005 (patch 354)
[muse-el.git] / debian / rules
blobf8e7bce3385aec733fed7fa71e055180487a3f11
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
5 # Uncomment this to turn on verbose mode.
6 #export DH_VERBOSE=1
7 LANG=C
8 LC_CTYPE=C
10 PACKAGE = muse-el
11 PKGDIR = debian/${PACKAGE}
12 DOCDIR = /usr/share/doc/${PACKAGE}
13 LISPDIR = /usr/share/emacs/site-lisp/${PACKAGE}
15 # This is the debhelper compatibility version to use.
16 export DH_COMPAT=4
18 configure: configure-stamp
19 configure-stamp:
20 dh_testdir
21 # Add here commands to configure the package.
23 touch configure-stamp
25 build: configure-stamp build-stamp
26 build-stamp:
27 dh_testdir
28 makeinfo muse.texi
29 makeinfo --html --output=html muse.texi
30 # Add here commands to compile the package.
31 $(MAKE) autoloads
32 $(MAKE) examples
33 #/usr/bin/docbook-to-man debian/muse.sgml > muse.1
35 touch build-stamp
37 clean:
38 dh_testdir
39 dh_testroot
40 rm -f build-stamp configure-stamp
41 # Add here commands to clean up after the build process.
42 -$(MAKE) realclean
44 dh_clean
46 install: build
47 dh_testdir
48 dh_testroot
49 dh_clean -k
50 dh_installdirs
52 # Add here commands to install the package into debian/muse.
53 # $(MAKE) install DESTDIR=$(CURDIR)/debian/muse
54 install -m 644 lisp/*.el $(PKGDIR)$(LISPDIR)
55 install -m 644 experimental/*.el $(PKGDIR)$(LISPDIR)/experimental
56 install -m 644 contrib/*.el $(PKGDIR)$(LISPDIR)/contrib
57 install -m 644 contrib/pyblosxom/*.py $(PKGDIR)$(DOCDIR)/contrib/pyblosxom
59 # Other documentation
60 install -m 0644 AUTHORS ${PKGDIR}${DOCDIR}/AUTHORS
61 install -m 0644 NEWS ${PKGDIR}${DOCDIR}/NEWS
62 install -m 0644 README ${PKGDIR}${DOCDIR}/README
63 install -m 0644 ChangeLog ${PKGDIR}${DOCDIR}/changelog
64 cat ChangeLog.2004 >> ${PKGDIR}${DOCDIR}/changelog
66 # Build architecture-independent files here.
67 binary-indep: build install
68 # We have nothing to do by default.
70 # Build architecture-dependent files here.
71 binary-arch: build install
72 dh_testdir
73 dh_testroot
74 # dh_installdebconf
75 dh_installdocs
76 dh_installexamples
77 # dh_installmenu
78 # dh_installlogrotate
79 dh_installemacsen
80 # dh_installpam
81 # dh_installmime
82 # dh_installinit
83 # dh_installcron
84 # dh_installman
85 dh_installinfo
86 # dh_undocumented
87 dh_installchangelogs
88 dh_link
89 dh_strip
90 dh_compress
91 dh_fixperms
92 # dh_makeshlibs
93 dh_installdeb
94 # dh_perl
95 # dh_shlibdeps
96 dh_gencontrol
97 dh_md5sums
98 dh_builddeb
100 binary: binary-indep binary-arch
101 .PHONY: build clean binary-indep binary-arch binary install configure