debian/: DEB_BUILD_OPTIONS -> DEB_BUILD_CONFIGURE
[mplayer.git] / debian / rules
blob60b19808ac69b251c29315bc74738497bcf28090
1 #!/usr/bin/make -f
2 # Made with the aid of debmake, by Christoph Lameter,
3 # based on the sample debian/rules file for GNU hello by Ian Jackson.
4 #export DH_VERBOSE=1
5 # This is the debhelper compatability version to use.
6 export DH_COMPAT=4
8 package := mplayer
9 prefix := $(shell pwd)/debian/$(package)
11 arch := $(shell dpkg --print-architecture)
13 # See http://wiki.debian.org/Teams/Dpkg/DebianRules; #465282 and
14 # https://wiki.ubuntu.com/DistCompilerFlags
15 CLEAN_ENV=env -u CFLAGS -u CPPFLAGS -u LDFLAGS -u FFLAGS -u CXXFLAGS
17 configure: configure-stamp
18 configure-stamp:
19 dh_testdir
20 # Add here commands to configure the package.
21 $(checkdir)
22 # If you plan to install the target .deb on a wide variety of machines,
23 # you may want to add the "--enable-runtime-cpudetection" option to
24 # the line below, but beware: the resulting binary will run slower
25 $(CLEAN_ENV) \
26 ./configure --prefix=/usr --confdir=/etc/mplayer $(DEB_BUILD_CONFIGURE)
28 touch configure-stamp
30 build: configure-stamp build-stamp
31 build-stamp:
32 dh_testdir
34 # commands to compile the package.
35 $(CLEAN_ENV) \
36 ${MAKE}
38 touch build-stamp
40 clean:
41 dh_testdir
42 dh_testroot
43 rm -f build-stamp configure-stamp
45 # commands to clean up after the build process.
46 -$(MAKE) distclean
47 rm -f help_mp.h config.h config.mak
48 dh_clean
50 # Build architecture-independent files here.
51 binary-indep: build
52 # We have nothing to do by default.
54 # Build architecture-dependent files here.
55 binary-arch: build
56 dh_testdir
57 dh_testroot
58 dh_clean -k
59 dh_installdirs
61 # commands to install the package into debian/<packagename>
62 $(MAKE) prefix=$(prefix)/usr BINDIR=$(prefix)/usr/bin CONFDIR=$(prefix)/etc/mplayer LIBDIR=$(prefix)/usr/lib DATADIR=$(prefix)/usr/share/mplayer MANDIR=$(prefix)/usr/share/man install
64 install -D -m 644 etc/example.conf $(prefix)/etc/mplayer/mplayer.conf
65 dh_installdocs -X.svn -Xmplayer.1 DOCS/*
66 dh_installexamples etc/example.conf etc/dvb-menu.conf etc/input.conf etc/menu.conf
67 dh_installmime
68 dh_installinfo
69 dh_installchangelogs
70 #ChangeLog
71 dh_link
72 dh_strip
73 dh_compress
74 dh_fixperms
75 dh_makeshlibs
76 dh_installdeb
77 dh_perl
78 dh_shlibdeps
79 dh_gencontrol
80 dh_md5sums
81 dh_builddeb
85 #binary-arch: checkroot build
86 # $(checkdir)
87 # -rm -rf debian/tmp
88 # install -d debian/tmp
89 # cd debian/tmp && install -d `cat ../dirs`
92 # Must have debmake installed for this to work. Otherwise please copy
93 # /usr/bin/debstd into the debian directory and change debstd to debian/debstd
94 # debstd
95 # dpkg-gencontrol -isp
96 # chown -R root.root debian/tmp
97 # chmod -R go=rX debian/tmp
98 # dpkg --build debian/tmp ..
100 binary: binary-indep binary-arch
102 .PHONY: binary binary-arch binary-indep clean checkroot