Update libav submodule
[mplayer-build.git] / debian / rules
blobb5a58702b1fe6f8f5662e78b8834215e9fa34de1
1 #!/usr/bin/make -f
2 # Made with the aid of debmake, by Christoph Lameter,
3 # based on the sample debian/rules file for GNU hello by Ian Jackson.
4 #export DH_VERBOSE=1
6 # do not run the actual rules of this makefile in parallel. sub-makes
7 # can go in parallel
8 .NOTPARALLEL:
10 package := mplayer
11 prefix := $(shell pwd)/debian/$(package)
13 arch := $(shell dpkg --print-architecture)
15 # See http://wiki.debian.org/Teams/Dpkg/DebianRules; #465282 and
16 # https://wiki.ubuntu.com/DistCompilerFlags
17 CLEAN_ENV=env -u CFLAGS -u CPPFLAGS -u LDFLAGS -u FFLAGS -u CXXFLAGS
19 ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
20 NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
21 MAKEFLAGS += -j$(NUMJOBS)
22 endif
24 configure: configure-stamp
25 configure-stamp:
26 dh_testdir
27 # Add here commands to configure the package.
28 $(checkdir)
29 # If you plan to install the target .deb on a wide variety of machines,
30 # you may want to add the "--enable-runtime-cpudetection" option to
31 # the line below, but beware: the resulting binary will run slower
32 ifneq (grep '--prefix' mplayer_options,0)
33 echo '--prefix=/usr' >> mplayer_options
34 endif
36 touch configure-stamp
38 build: configure-stamp build-stamp
39 build-stamp:
40 dh_testdir
42 # commands to compile the package.
43 $(CLEAN_ENV) \
44 ${MAKE}
46 touch build-stamp
48 clean:
49 dh_testdir
50 dh_testroot
51 rm -f build-stamp configure-stamp
53 # commands to clean up after the build process.
54 ./clean
55 dh_clean
57 # Build architecture-independent files here.
58 binary-indep: build
59 # We have nothing to do by default.
61 # Build architecture-dependent files here.
62 binary-arch: build
63 dh_testdir
64 dh_testroot
65 dh_clean -k
66 dh_installdirs
68 # commands to install the package into debian/<packagename>
69 $(MAKE) prefix=$(prefix)/usr BINDIR=$(prefix)/usr/bin CONFDIR=$(prefix)/etc/mplayer LIBDIR=$(prefix)/usr/lib DATADIR=$(prefix)/usr/share/mplayer MANDIR=$(prefix)/usr/share/man install
71 install -D -m 644 mplayer/etc/example.conf $(prefix)/etc/mplayer/mplayer.conf
72 dh_installdocs -X.svn -Xmplayer.1 mplayer/DOCS/*
73 dh_installexamples mplayer/etc/example.conf mplayer/etc/input.conf
74 dh_installmime
75 dh_installinfo
76 dh_installchangelogs
77 #ChangeLog
78 dh_link
79 dh_strip
80 dh_compress
81 dh_fixperms
82 dh_makeshlibs
83 dh_installdeb
84 dh_shlibdeps
85 dh_gencontrol
86 dh_md5sums
87 dh_builddeb
89 binary: binary-indep binary-arch
91 .PHONY: binary binary-arch binary-indep clean checkroot