Remove unmaintained packages - #557728 @bgo
[moonrise.git] / net-p2p / rtorrent / rtorrent-0.8.7.ebuild
blob70f46118fac1d4fab5029f2aaf453c0a3072a6c1
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.8.6.ebuild,v 1.3 2010/01/21 11:19:34 cla Exp $
5 EAPI=2
7 inherit eutils
9 DESCRIPTION="BitTorrent Client using libtorrent"
10 HOMEPAGE="http://libtorrent.rakshasa.no/"
11 SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
16 IUSE="daemon debug ipv6 xmlrpc"
18 COMMON_DEPEND=">=net-libs/libtorrent-0.12.${PV##*.}
19 >=dev-libs/libsigc++-2.2.2:2
20 >=net-misc/curl-7.19.1
21 sys-libs/ncurses
22 xmlrpc? ( dev-libs/xmlrpc-c )"
23 RDEPEND="${COMMON_DEPEND}
24 daemon? ( app-misc/screen )"
25 DEPEND="${COMMON_DEPEND}
26 dev-util/pkgconfig"
28 src_configure() {
29 econf \
30 --disable-dependency-tracking \
31 $(use_enable debug) \
32 $(use_enable ipv6) \
33 $(use_with xmlrpc xmlrpc-c)
36 src_install() {
37 emake DESTDIR="${D}" install || die
38 dodoc AUTHORS README TODO doc/rtorrent.rc
40 if use daemon; then
41 newinitd "${FILESDIR}/rtorrentd.init" rtorrentd || die "newinitd failed"
42 newconfd "${FILESDIR}/rtorrentd.conf" rtorrentd || die "newconfd failed"