media-video/subget: add 1.5.2
[moonrise.git] / media-video / subget / subget-1.5.2.ebuild
blobfe1a2d66e9c13f0659b4605fa447cb0399635128
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $
5 EAPI="3"
6 SUPPORT_PYTHON_ABIS="1"
7 PV="1.5.1"
9 inherit git distutils
11 MY_P="subget-${PV}"
13 DESCRIPTION="Simple Subtitles downloading program for Linux with PyGTK. Supports plugins and multi-language."
14 HOMEPAGE="https://github.com/webnull/subget"
15 SRC_URI=""
17 EGIT_REPO_URI="git://github.com/webnull/subget.git"
18 EGIT_BRANCH="master"
20 LICENSE="GPL-3"
21 SLOT="0"
22 KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
23 IUSE="dbus"
25 DEPEND="dev-lang/python
26 ( app-arch/p7zip )
27 ( dev-python/pygtk )
28 dbus? ( dev-python/dbus-python )
29 ( sys-devel/gettext )"
30 RDEPEND="${DEPEND}"
32 src_install() {
33 if !use dbus; then
34 rm src/subgetlib/bus.py
37 distutils_src_install
39 mv subget.py subget
40 exeinto /usr/bin
41 doexe subget
43 insinto /usr/share/applications
44 doins usr/share/applications/subget.desktop
46 insinto /usr/share/menu
47 doins usr/share/menu/subget
49 insinto /usr/share/
50 doins -r usr/share/subget