Remove outdated ebuilds
[moonrise.git] / app-misc / kupfer / kupfer-206.ebuild
blob8a33f5f4667f3f5bece8009d4d3e4797610e659d
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI=3
6 inherit waf-utils eutils
8 DESCRIPTION="kupfer, a convenient command and access tool"
9 HOMEPAGE="http://kaizer.se/wiki/kupfer/"
11 MY_P="${PN}-v${PV}"
13 SRC_URI="http://kaizer.se/publicfiles/${PN}/${MY_P}.tar.gz"
15 LICENSE="GPL-3"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="+keybinder doc nautilus"
20 COMMON_DEPEND=">=dev-lang/python-2.6
21 dev-python/pygtk
22 dev-python/pyxdg
23 dev-python/dbus-python
24 dev-python/libwnck-python
25 dev-python/pygobject
26 dev-python/libgnome-python"
27 # dev-python/gnome-keyring-python doesn't work well with Kupfer
28 # dev-python/gnome-keyring-python
29 DEPEND="${COMMON_DEPEND}
30 dev-python/docutils
31 doc? ( app-text/gnome-doc-utils )
32 dev-util/intltool"
33 RDEPEND="${COMMON_DEPEND}
34 keybinder? ( dev-libs/keybinder )
35 nautilus? ( gnome-base/nautilus )"
37 S=${WORKDIR}/${MY_P}
39 src_prepare() {
40 epatch "${FILESDIR}/${P}-xfce4-terminal.patch"
43 src_configure() {
44 local myopts=""
45 use nautilus || myopts="--no-install-nautilus-extension"
46 waf-utils_src_configure --no-update-mime $myopts || \
47 die "Error: configure failed!"
50 src_install() {
51 waf-utils_src_install || die "Error: install failed!"
52 if ! use doc; then
53 rm -rf "${ED}"usr/share/gnome/help/kupfer