Remove outdated ebuilds
[moonrise.git] / app-misc / kupfer / kupfer-203.ebuild
blob19e55c61ffa218ae79f3566384fefd4e0123f8f8
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI=3
7 DESCRIPTION="Fast and lightweight desktop launcher"
8 HOMEPAGE="http://kaizer.se/wiki/kupfer/"
10 MY_P="${PN}-v${PV}"
12 SRC_URI="http://kaizer.se/publicfiles/${PN}/${MY_P}.tar.gz"
14 LICENSE="GPL-3"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE="+keybinder"
19 DEPEND=">=dev-lang/python-2.6
20 sys-devel/gcc
21 dev-python/pygtk
22 dev-python/pyxdg
23 dev-python/dbus-python
24 dev-python/libwnck-python
25 dev-python/pygobject
26 dev-python/libgnome-python
27 dev-python/gnome-keyring-python
28 keybinder? ( dev-libs/keybinder )"
29 RDEPEND="${DEPEND}"
31 S=${WORKDIR}/${MY_P}
33 src_prepare() {
34 sed -i "s/keyring/gnomekeyring/" wscript || die
35 sed -i "s/import keyring/import gnomekeyring/" \
36 kupfer/core/settings.py || \
37 die "Error: src_prepare failed!"
40 src_configure() {
41 ./waf configure --prefix=/usr || die "Error: configure failed!"
44 src_compile() {
45 ./waf || die "Error: src_compile failed!"
48 src_install() {
49 ./waf --destdir="${D}" install || die "Error: src_install failed!"