SOAP API: do not try to unserialize an invalid filter
[mantis.git] / packages / mantis.spec
blobf869341ec2986cf48c55fb98e51b4bb639e437a9
1 # %global pkgdir %_datadir/%name
2 %global pkgdir /var/www/%name
3 %global cfgdir %_sysconfdir/%name
4 %global httpconfdir %_sysconfdir/httpd/conf.d
6 Summary: Mantis Bugtracker
7 Name: mantis
8 Version: 1.1.0a3
9 Release: 20051130
10 License: GPL
11 Group: Applications/Internet
12 URL: http://www.mantisbugtracker.com/
13 BuildArch: noarch
14 Source0: http://download.sourceforge.net/sourceforge/mantisbt/%name-%version-%release.tar.gz
15 Source1: mantis-httpd.conf
16 BuildRoot: %_tmppath/%name-%version-%release-buildroot
17 BuildRequires: diffutils
18 Requires: php
21 %description
22 Mantis is a web-based bugtracking system. It is written in the PHP
23 scripting language and requires the MySQL database and a webserver.
24 Mantis has been installed on Windows, MacOS, OS/2, and a variety of
25 Unix operating systems. Any web browser should be able to function
26 as a client. It is released under the terms of the GNU General
27 Public License (GPL).
30 %prep
31 %setup -n %{name}-%{version}-%{release} -q
33 chmod -x *.php
34 rm -rf packages
37 %install
38 rm -rf "$RPM_BUILD_ROOT"
39 %__install -d -m755 $RPM_BUILD_ROOT%pkgdir
40 %__install -d -m750 $RPM_BUILD_ROOT%cfgdir
42 tar cf - . | tar xf - -C $RPM_BUILD_ROOT%pkgdir
44 find $RPM_BUILD_ROOT \( \
45 -name '*.noexamplecom' -o -name '*.iis' -o -name '*.noadmin' -o -name '*.#.*' -o \
46 -name '.cvsignore' \
47 \) -print0 | xargs -0 rm -f
49 ## Do not rename; the *existence* of this file will be checked to
50 ## determine if mantis is offline
51 mv $RPM_BUILD_ROOT%pkgdir/mantis_offline.php.sample $RPM_BUILD_ROOT%cfgdir/
52 mv $RPM_BUILD_ROOT%pkgdir/config_inc.php.sample $RPM_BUILD_ROOT%cfgdir/config_inc.php
54 ln -s %cfgdir/config_inc.php $RPM_BUILD_ROOT%pkgdir/config_inc.php
55 ln -s %cfgdir/mantis_offline.php $RPM_BUILD_ROOT%pkgdir/mantis_offline.php
57 ## The httpd config-files
58 function subst() {
59 f=$RPM_BUILD_ROOT$1
60 sed -e 's!/usr/share/mantis!%pkgdir!g' "$f" >"$f".tmp
61 cmp -s "$f" "$f.tmp" || cat "$f.tmp" >"$f"
62 rm -f "$f.tmp"
65 %__install -d $RPM_BUILD_ROOT%httpconfdir
66 %__install -p -m644 %SOURCE1 $RPM_BUILD_ROOT%httpconfdir/mantis.conf
67 subst %httpconfdir/mantis.conf
70 %clean
71 rm -rf "$RPM_BUILD_ROOT"
74 %post
75 #/etc/init.d/httpd restart
78 %files
79 %defattr(-,root,root,-)
80 %doc doc/*
81 %pkgdir
82 %attr(-,root,apache) %dir %cfgdir
83 %attr(0640,root,apache) %config(noreplace) %cfgdir/*
84 %config(noreplace) %httpconfdir/*
87 %changelog
88 * Wed Dec 03 2005 Victor Boctor
89 - Updated summary, description and URL. Also added to CVS.
91 * Wed Nov 30 2005 Iain Lea <iain@bricbrac.de> - 1.1.0-cvs
92 - updated to build single RPM from 1.1.0-cvs
94 * Sat Jun 25 2005 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 1.0.0
95 - updated to 1.0.0a3
96 - removed the part which created the psql-script; upstream has now a
97 working PostgreSQL database creation script
98 - rediffed the -iis patch
99 - added patch to make upgrade functionionality partially working with
100 PostgreSQL; this is not perfect as things like index creation will
101 still fail
103 * Thu May 19 2005 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0.19.2-2
104 - use %%dist instead of %%disttag
106 * Mon Mar 7 2005 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0.19.2-1
107 - updated to 0.19.2
108 - rediffed patches
109 - removed dependency on php-mysql as it supports PostgreSQL also
110 - added inline-hack to generate a PostgreSQL database creation script
112 * Thu May 27 2004 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.18.3-0.fdr.2
113 - ship doc/ in the program-directory instead of copying it into %%docdir
114 - modified shipped httpd configuration to disable admin/ directory
115 explicitly and added some documentation there
116 - added noadmin patch to disable warning about existing admin/ directory;
117 since this directory is disabled by httpd configuration
118 - lower restrictions on the required 'mantis-config' subpackage; use
119 descriptive names as version instead of EVR
120 - restart 'httpd' after the upgrade
121 - preserve timestamps of the configuration files to avoid creation of
122 .rpmnew files on every update
124 * Tue May 25 2004 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.18.3-0.fdr.0.1
125 - updated to 0.18.2
126 - rediffed the patches
128 * Fri Aug 15 2003 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> 0:0.18.0-0.fdr.0.2.a4
129 - use generic download-address for Source0
131 * Thu Jun 19 2003 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> 0:0.18.0-0.fdr.0.1.a4
132 - applied the Fedora naming standard
134 * Thu Jun 19 2003 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> 0:0.18.0-0.fdr.0.a4.2
135 - Initial build.