Late commit of license change
[make-srpm.git] / make-srpm.spec
blob89b9df61f93c53629e3829b39016895e622c9c9b
1 # make-srpm: srpm builder, helps build srpm out of rcs sources
3 # Copyright (C) 2009-2010 Sam Liddicott <sam@liddicott.com>
5 # This program is free software; you can redistribute it and/or modify
6 # it under the terms of the GNU General Public License as published by
7 # the Free Software Foundation; either version 3 of the License, or
8 # (at your option) any later version.
10 # This program is distributed in the hope that it will be useful,
11 # but WITHOUT ANY WARRANTY; without even the implied warranty of
12 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
13 # GNU General Public License for more details.
15 # You should have received a copy of the GNU General Public License
16 # along with this program. If not, see <http://www.gnu.org/licenses/>.
19 #makesrpm-RELEASE: HEAD
20 #makesrpm-ORIGIN_PATTERN: v*
21 #makesrpm-VERSION_PATTERN: v*
22 #makesrpm-PATCH_LEVEL: 1
24 Name: make-srpm-vcs
25 Source: %makesrpm_tarname
26 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
27 URL: http://repo.or.cz/w/make-srpm.git
28 License: GPL3 or later
29 Summary: make-srpm build and export tool for GIT and SVN
30 Group: Development/Utilities
31 Version:
32 Release: %{release}-%{?dist}
33 Epoch: 0
35 %description
36 Helps production of RPM's from GIT or SVN source trees.
37 Useful for rebase trees of local changes against an official release.
39 A pristine source tar.gz is produced, with a series of patches up to the current released
41 %prep
42 %setup -q -n %makesrpm_tarprefix
44 %build
46 %install
48 rm -rf $RPM_BUILD_ROOT
49 mkdir -p $RPM_BUILD_ROOT/
51 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
52 mkdir -p $RPM_BUILD_ROOT/%{_libdir}/make-srpm
54 install -m 0755 -t $RPM_BUILD_ROOT/%{_bindir} make-srpm
55 install -m 0755 -t $RPM_BUILD_ROOT/%{_libdir}/make-srpm make-srpm_*
57 %clean
58 rm -rf $RPM_BUILD_ROOT
60 %files
61 %defattr(-,root,root)
62 %{_bindir}/
63 %{_libdir}/
65 %changelog
66 * Wed Jun 24 2009 Sam Liddicott <sam@liddicott.com>
67 - Dog-food build. (First spec file for make-srpm)