FS#12750 by Vanja Cvelbar - update Slovenian translation
[maemo-rb.git] / debian / rules
blobf039a557943cd9a1e755914c308f24975bcca57d
1 #!/usr/bin/make -f
3 # We deduce the target based on the available version of the Maemo SDK
4 ifeq (1,$(shell pkg-config --atleast-version=5 maemo-version && echo 1))
5 TARGET=nokian900
6 else
7 TARGET=nokian8xx
8 endif
10 CONFIGURE_OPTIONS := --target=$(TARGET) --ram=8 --rbdir=/.rockbox --type=N
11 DESKTOP_DIR := `pkg-config --variable=desktopentrydir osso-af-settings`
13 export DH_VERBOSE=1
15 builddir:
16 test -d builddir || mkdir -p builddir
18 builddir/Makefile: builddir
19 cd builddir && test -f Makefile || ../tools/configure $(CONFIGURE_OPTIONS)
21 build: build-stamp
23 build-stamp: builddir/Makefile
24 dh_testdir
25 cd builddir && $(MAKE)
26 touch $@
28 clean:
29 dh_testdir
30 dh_testroot
31 rm -f build-stamp
32 rm -rf builddir
33 dh_clean
34 install: build
35 dh_testdir
36 dh_testroot
37 dh_clean -k
38 dh_installdirs
40 cd builddir && $(MAKE) PREFIX=$(CURDIR)/debian/rockbox/opt/rockbox fullinstall
42 # Install icon and .desktop file
43 mkdir -p $(CURDIR)/debian/rockbox/usr/share/icons/hicolor/64x64/apps
44 cp -f debian/maemo/rockbox.png $(CURDIR)/debian/rockbox/usr/share/icons/hicolor/64x64/apps
45 mkdir -p $(CURDIR)/debian/rockbox$(DESKTOP_DIR)
46 cp -f debian/maemo/rockbox.desktop $(CURDIR)/debian/rockbox$(DESKTOP_DIR)
48 # Ignore built in sounds
49 mkdir -p $(CURDIR)/debian/rockbox/usr/share/sounds
50 touch $(CURDIR)/debian/rockbox/usr/share/sounds/database.ignore
52 # Build architecture-independent files here.
53 binary-indep:
54 # We have nothing to do by default.
56 # Build architecture-dependent files here.
57 binary-arch: build install
58 dh_testdir
59 dh_testroot
60 dh_installdocs
61 dh_installexamples
62 dh_installman
63 dh_link
64 dh_strip --dbg-package=rockbox-dbg
65 dh_compress
66 dh_fixperms
67 dh_installdeb
68 dh_shlibdeps
69 dh_gencontrol
70 dh_md5sums
71 dh_builddeb
73 binary: binary-indep binary-arch
74 .PHONY: build clean binary-indep binary-arch binary install configure