Respect ${LINGUAS} for kguitar
[kdeapps-overlay.git] / media-sound / kguitar / kguitar-0.5.1.ebuild
blobb14855f87e9bc93cdf3b0ba1f8215e77b9f6582a
1 # KDE-Apps Gentoo Overlay
2 # Maintained by Bram Schoenmakers <bramschoenmakers@kde.nl>
4 # Distributed under the terms of the GNU General Public License v3
5 # Copyright 2008
7 LANGS="de es fr it ru"
9 inherit kde
11 DESCRIPTION="KGuitar is a guitarist helper program focusing on tabulature editing and MIDI synthesizers support."
12 HOMEPAGE="http://kguitar.sf.net"
13 LICENSE="GPL-2"
14 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
16 IUSE="kgtabs"
17 KEYWORDS="~amd64 ~x86"
18 SLOT="0"
20 RDEPEND=">=media-libs/tse3-0.2.3"
21 DEPEND="${REDPEND}"
23 src_compile()
25 local myconf="$(use_with kgtabs)"
27 kde_src_compile
30 src_unpack()
32 kde_src_unpack
33 strip-linguas ${LANGS}
35 if [[ ${LINGUAS} != "" ]]; then
36 LANGPO=""
37 for I in ${LINGUAS}; do
38 LANGPO="${LANGPO} ${I}.po"
39 done
41 sed -i -e "s/^POFILES =.*/POFILES =${LANGPO}/" "${S}/po/Makefile.am" || die "sed for locale failed"
42 rm -f "${KDE_S}/configure"
46 need-kde 3