bump 0.8.2.1
[intricacy.git] / PKGBUILD
blob4f8ab02f2e0d0bf0b5d2f1061e04a9cf7bdf1562
1 # custom variables
2 _hkgname=intricacy
3 _licensefile=COPYING
5 # PKGBUILD options/directives
6 pkgname=intricacy
7 pkgver=0.8.2.1
8 pkgrel=1
9 pkgdesc="A game of competitive puzzle-design"
10 url="http://mbays.freeshell.org/intricacy"
11 license=("GPL-3")
12 arch=('i686' 'x86_64')
13 makedepends=('ghc')
14 depends=()
15 options=('strip')
16 source=("http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
18 sha256sums=("ffe62181ad55592a7fc07d3f08790f80a4683883b9eb0bdba7745636ad167cfb")
20 # PKGBUILD functions
22 prepare() {
23     cd "${srcdir}/${_hkgname}-${pkgver}"
24     
25     # no cabal patch
26     # no source patch
29 build() {
30     cd "${srcdir}/${_hkgname}-${pkgver}"
31     
32     runhaskell Setup configure -O --prefix=/usr --docdir="/usr/share/doc/${pkgname}" \
33         -f-server -fgame -fcurses -fsdl
34     runhaskell Setup build
37 package() {
38     cd "${srcdir}/${_hkgname}-${pkgver}"
39     runhaskell Setup copy --destdir="${pkgdir}"