ports: Don't use the `SCM_BUF0' flag.
[guile-r6rs-libs.git] / debian / rules
blob0d592147c75d4b49c55449cca1c541ae89207fc8
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
15 configure: configure-stamp
16 configure-stamp:
17 dh_testdir
18 [ -f configure ] || \
19 ( gnulib-tool --update && autoreconf -i --force )
20 PATH=/usr/bin:$$PATH \
21 ./configure --prefix=/usr \
22 --with-guilemoduledir=/usr/share/guile/site \
23 --infodir=/usr/share/info
24 touch configure-stamp
27 build: build-stamp
29 build-stamp: configure-stamp
30 dh_testdir
32 $(MAKE) check
33 #docbook-to-man debian/guile-r6rs-libs.sgml > guile-r6rs-libs.1
35 touch $@
37 clean:
38 dh_testdir
39 dh_testroot
40 rm -f build-stamp configure-stamp
42 [ ! -f Makefile ] || $(MAKE) distclean
44 dh_clean
46 install: build
47 dh_testdir
48 dh_testroot
49 dh_clean -k
50 dh_installdirs
52 # Add here commands to install the package into debian/guile-r6rs-libs.
53 $(MAKE) DESTDIR=$(CURDIR)/debian/guile-r6rs-libs install
56 # Build architecture-independent files here.
57 binary-indep: build install
58 # We have nothing to do by default.
60 # Build architecture-dependent files here.
61 binary-arch: build install
62 dh_testdir
63 dh_testroot
64 dh_installchangelogs ChangeLog
65 dh_installdocs
66 # dh_installexamples
67 # dh_install
68 # dh_installinit
69 # dh_installinfo
70 dh_installman
71 dh_link
72 dh_strip
73 dh_compress
74 dh_fixperms
75 dh_makeshlibs
76 dh_installdeb
77 dh_shlibdeps
78 dh_gencontrol
79 dh_md5sums
80 dh_builddeb
82 binary: binary-indep binary-arch
83 .PHONY: build clean binary-indep binary-arch binary install configure