Initial import of the Debian package.
[guile-r6rs-libs.git] / debian / rules
blobc9096394a3a8915a363740ddf5b7e70e69db4427
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
15 configure: configure-stamp
16 configure-stamp:
17 dh_testdir
18 [ -f configure ] || \
19 ( gnulib-tool --update && autoreconf -i --force )
20 ./configure --datadir=/usr/share/guile/site --prefix=/usr \
21 --infodir=/usr/share/info
22 touch configure-stamp
25 build: build-stamp
27 build-stamp: configure-stamp
28 dh_testdir
30 # Add here commands to compile the package.
31 $(MAKE)
32 #docbook-to-man debian/guile-r6rs-libs.sgml > guile-r6rs-libs.1
34 touch $@
36 clean:
37 dh_testdir
38 dh_testroot
39 rm -f build-stamp configure-stamp
41 [ ! -f Makefile ] || $(MAKE) clean
43 dh_clean
45 install: build
46 dh_testdir
47 dh_testroot
48 dh_clean -k
49 dh_installdirs
51 # Add here commands to install the package into debian/guile-r6rs-libs.
52 $(MAKE) DESTDIR=$(CURDIR)/debian/guile-r6rs-libs install
55 # Build architecture-independent files here.
56 binary-indep: build install
57 # We have nothing to do by default.
59 # Build architecture-dependent files here.
60 binary-arch: build install
61 dh_testdir
62 dh_testroot
63 dh_installchangelogs ChangeLog
64 dh_installdocs
65 dh_installexamples
66 # dh_install
67 # dh_installinit
68 # dh_installcron
69 dh_installinfo
70 dh_installman
71 dh_link
72 dh_strip
73 dh_compress
74 dh_fixperms
75 # dh_perl
76 # dh_makeshlibs
77 dh_installdeb
78 dh_shlibdeps
79 dh_gencontrol
80 dh_md5sums
81 dh_builddeb
83 binary: binary-indep binary-arch
84 .PHONY: build clean binary-indep binary-arch binary install configure