Update copyright notices with scripts/update-copyrights
[glibc.git] / ports / sysdeps / m68k / Makefile
blob58ebd5ec4a3b8ed2edd05ef74c904c2bd009123a
1 # Copyright (C) 1993-2014 Free Software Foundation, Inc.
2 # This file is part of the GNU C Library.
4 # The GNU C Library is free software; you can redistribute it and/or
5 # modify it under the terms of the GNU Lesser General Public
6 # License as published by the Free Software Foundation; either
7 # version 2.1 of the License, or (at your option) any later version.
9 # The GNU C Library is distributed in the hope that it will be useful,
10 # but WITHOUT ANY WARRANTY; without even the implied warranty of
11 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
12 # Lesser General Public License for more details.
14 # You should have received a copy of the GNU Lesser General Public
15 # License along with the GNU C Library. If not, see
16 # <http://www.gnu.org/licenses/>.
18 # The mpn functions need this. All existing 68k ports use MIT syntax. If
19 # a new port wants to use Motorola or Sony syntax, it can redefine this
20 # variable.
21 ifndef m68k-syntax-flag
22 m68k-syntax-flag = -DMIT_SYNTAX
23 endif
25 asm-CPPFLAGS += $(m68k-syntax-flag)
27 pic-ccflag = -fpic
29 ifeq ($(subdir),setjmp)
30 # Make sure setjmp.c is compiled with a frame pointer
31 CFLAGS-setjmp.c := -fno-omit-frame-pointer
32 endif
34 ifeq ($(subdir),debug)
35 CFLAGS-backtrace.c += -funwind-tables
36 endif
38 ifeq ($(subdir),elf)
39 CFLAGS-rtld.c += -Wno-uninitialized -Wno-unused
40 endif