Update copyright notices with scripts/update-copyrights
[glibc.git] / ports / sysdeps / hppa / Makefile
blobfa9bc206a22fc64e032514e36b849edcb83625cb
1 # Copyright (C) 2000-2014 Free Software Foundation, Inc.
2 # This file is part of the GNU C Library.
3 # Contributed by David Huggins-Daines (dhd@debian.org)
5 # The GNU C Library is free software; you can redistribute it and/or
6 # modify it under the terms of the GNU Lesser General Public
7 # License as published by the Free Software Foundation; either
8 # version 2.1 of the License, or (at your option) any later version.
10 # The GNU C Library is distributed in the hope that it will be useful,
11 # but WITHOUT ANY WARRANTY; without even the implied warranty of
12 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
13 # Lesser General Public License for more details.
15 # You should have received a copy of the GNU Lesser General Public
16 # License along with the GNU C Library. If not, see
17 # <http://www.gnu.org/licenses/>.
19 # We used to need this since the build process uses ld -r. Now we use
20 # ld -r --unique=.text* which does more or less the same thing, but better.
21 # CFLAGS-.os += -ffunction-sections
22 LDFLAGS-c_pic.os += -Wl,--unique=.text*
24 ifeq ($(subdir),elf)
25 CFLAGS-rtld.c += -mdisable-fpregs
26 sysdep-dl-routines += dl-symaddr dl-fptr
27 sysdep_routines += $(sysdep-dl-routines)
28 sysdep-rtld-routines += $(sysdep-dl-routines)
29 endif
31 ifeq ($(subdir),csu)
32 ifeq (yes,$(build-shared))
33 # Compatibility
34 ifeq (yes,$(have-protected))
35 CPPFLAGS-libgcc-compat.c = -DHAVE_DOT_HIDDEN
36 endif
37 sysdep_routines += libgcc-compat
38 shared-only-routines += libgcc-compat
39 endif
40 endif
42 # We implement a 64-bit `long double'. The standard says we can do this.
43 # This means our `long double' and `double' are identical.
44 long-double-fcts = no