Update copyright notices with scripts/update-copyrights
[glibc.git] / ports / sysdeps / alpha / Makefile
blob1cf77fb239beb4cbd0b63e2a48ab6bf265debf61
1 # Copyright (C) 1993-2014 Free Software Foundation, Inc.
2 # This file is part of the GNU C Library.
3 # Contributed by Brendan Kehoe (brendan@zen.org).
5 # The GNU C Library is free software; you can redistribute it and/or
6 # modify it under the terms of the GNU Lesser General Public
7 # License as published by the Free Software Foundation; either
8 # version 2.1 of the License, or (at your option) any later version.
10 # The GNU C Library is distributed in the hope that it will be useful,
11 # but WITHOUT ANY WARRANTY; without even the implied warranty of
12 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
13 # Lesser General Public License for more details.
15 # You should have received a copy of the GNU Lesser General Public
16 # License along with the GNU C Library. If not, see
17 # <http://www.gnu.org/licenses/>.
19 ifeq ($(subdir),db2)
20 CPPFLAGS += -DHAVE_SPINLOCKS=1 -DHAVE_ASSEM_ALPHA=1
21 endif
23 ifeq ($(subdir),gmon)
24 sysdep_routines += _mcount
25 endif
27 ifeq ($(subdir),gnulib)
28 sysdep_routines += divl divlu divq divqu reml remlu remq remqu
29 endif
31 ifeq ($(subdir),string)
32 sysdep_routines += stxcpy stxncpy
33 endif
35 ifeq ($(subdir),elf)
36 # The ld.so startup code cannot use literals until it self-relocates.
37 CFLAGS-rtld.c = -mbuild-constants
38 endif
40 ifeq ($(subdir),math)
41 # The fma routines rely on inexact being raised for correct results.
42 CFLAGS-s_fma.c = -mieee-with-inexact
43 CFLAGS-s_fmaf.c = -mieee-with-inexact
44 # This test tries to check for inexact being raised by arithmetic.
45 CFLAGS-test-misc.c += -mieee-with-inexact
46 # Avoid "conflicting types for built-in function" warnings
47 CFLAGS-s_isnan.c += -fno-builtin-isnanf
48 endif
50 # Build everything with full IEEE math support, and with dynamic rounding;
51 # there are a number of math routines that are defined to work with the
52 # "current" rounding mode, and it's easiest to set this with all of them.
53 sysdep-CFLAGS += -mieee -mfp-rounding-mode=d
55 # libc.so requires about 16k for the small data area, which is well
56 # below the 64k maximum.
57 pic-ccflag = -fpic