debian: git-gui: Sort entries in optimized tclIndex
[git/debian.git] / debian / patches / git-gui-Sort-entries-in-optimized-tclIndex.diff
blob2153d43118c1f80325bb6223153e93c271e61447
1 From c526d5010f32b5dd18fd176de1b7def49a5d6d65 Mon Sep 17 00:00:00 2001
2 From: Anders Kaseorg <andersk@mit.edu>
3 Date: Wed, 16 Nov 2016 16:37:17 -0500
4 Subject: git-gui: Sort entries in optimized tclIndex
5 MIME-Version: 1.0
6 Content-Type: text/plain; charset=UTF-8
7 Content-Transfer-Encoding: 8bit
9 auto_mkindex expands wildcards in directory order, which depends on
10 the underlying filesystem. To improve build reproducibility, sort the
11 list of *.tcl files in the Makefile.
13 The unoptimized loading case was previously fixed in
14 v2.11.0-rc0~31^2^2~14 “git-gui: sort entries in tclIndex”.
16 Signed-off-by: Anders Kaseorg <andersk@mit.edu>
17 ---
18 git-gui/Makefile | 2 +-
19 1 file changed, 1 insertion(+), 1 deletion(-)
21 diff --git a/git-gui/Makefile b/git-gui/Makefile
22 index fe30be38d..f94b3e13d 100644
23 --- a/git-gui/Makefile
24 +++ b/git-gui/Makefile
25 @@ -252,7 +252,7 @@ $(ALL_MSGFILES): %.msg : %.po
26 lib/tclIndex: $(ALL_LIBFILES) GIT-GUI-VARS
27 $(QUIET_INDEX)if echo \
28 $(foreach p,$(PRELOAD_FILES),source $p\;) \
29 - auto_mkindex lib '*.tcl' \
30 + auto_mkindex lib $(patsubst lib/%,%,$(sort $(ALL_LIBFILES))) \
31 | $(TCL_PATH) $(QUIET_2DEVNULL); then : ok; \
32 else \
33 echo >&2 " * $(TCL_PATH) failed; using unoptimized loading"; \
34 --
35 2.11.0.rc2