debian: add Breaks relation to help dgit upgrades
[git/debian.git] / debian / rules
blobe19901b44ad7fd74fc349872e983d136d9063c53
1 #!/usr/bin/make -f
3 CC =gcc
4 CPPFLAGS :=$(shell dpkg-buildflags --get CPPFLAGS)
5 CFLAGS :=-Wall $(shell dpkg-buildflags --get CFLAGS) $(CPPFLAGS)
6 LDFLAGS :=$(shell dpkg-buildflags --get LDFLAGS)
7 TEST =test
8 OPTS =NO_OPENSSL=1 prefix=/usr gitexecdir=/usr/lib/git-core \
9 libexecdir=/usr/lib/git-core \
10 mandir=/usr/share/man htmldir=/usr/share/doc/git/html \
11 INSTALLDIRS=vendor \
12 SANE_TOOL_PATH= INSTALL=install TAR=tar \
13 NO_CROSS_DIRECTORY_HARDLINKS=1 NO_INSTALL_HARDLINKS=1 \
14 NO_PERL_CPAN_FALLBACKS=1 \
15 DEFAULT_PAGER=pager DEFAULT_EDITOR=editor \
16 V=1 \
17 CC='$(CC)' CFLAGS='$(CFLAGS)' LDFLAGS='$(LDFLAGS)'
18 DOCS =html
19 DOC_OPTS =prefix=/usr htmldir=/usr/share/doc/git/html \
20 V=1 \
21 ASCIIDOC8=1 ASCIIDOC_NO_ROFF=1
23 # https://wiki.debian.org/ReproducibleBuilds/TimestampsInDocumentationGeneratedByAsciidoc
24 DOC_OPTS += ASCIIDOC='TZ=UTC asciidoc'
26 ifneq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
27 TEST =
28 endif
29 ifneq (,$(findstring nodoc,$(DEB_BUILD_OPTIONS)))
30 DOCS =
31 endif
32 ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
33 NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
34 MAKEFLAGS += -j$(NUMJOBS)
35 # Setting this with a pattern-specific rule prevents -O from
36 # affecting the top-level make, which would break realtime build
37 # output (unless dh is run as +dh, which causes other problems).
38 %: MAKEFLAGS += -O
39 endif
40 ifneq (,$(shell dpkg-query -f '$${Version}' -W libpcre2-dev))
41 OPTS += USE_LIBPCRE2=1
42 else
43 OPTS += USE_LIBPCRE1=1
44 endif
46 TMP = $(CURDIR)/debian/tmp
47 GIT = $(CURDIR)/debian/git
50 dh $@ --with apache2
52 override_dh_auto_configure:
54 build-stamp:
55 -$(CC) -v
56 $(MAKE) all $(OPTS)
57 touch $@
59 override_dh_auto_build-arch: build-stamp
60 $(MAKE) -C contrib/subtree all $(OPTS)
61 ln -s contrib/subtree/git-subtree
63 override_dh_auto_test-arch:
64 test -z '$(TEST)' || \
65 GIT_SKIP_TESTS="t9128 t9167" \
66 GIT_TEST_OPTS=--verbose $(MAKE) $(TEST) $(OPTS)
67 test -z '$(TEST)' || \
68 GIT_TEST_OPTS=--verbose \
69 $(MAKE) -C t \
70 t9128-git-svn-cmd-branch.sh \
71 t9167-git-svn-cmd-branch-subproject.sh \
72 $(OPTS) || :
73 test -z '$(TEST)' || \
74 GIT_TEST_OPTS=--verbose $(MAKE) -C contrib/subtree $(TEST) $(OPTS)
76 override_dh_auto_build-indep: build-stamp
77 # git-man, git-doc
78 $(MAKE) -CDocumentation man $(DOCS) $(DOC_OPTS)
79 # git-mediawiki
80 $(MAKE) -Ccontrib/mw-to-git all $(OPTS)
82 override_dh_auto_test-indep:
84 override_dh_auto_clean:
85 $(MAKE) -C contrib/mw-to-git clean $(OPTS)
86 $(MAKE) -C contrib/subtree clean $(OPTS)
87 $(MAKE) clean $(OPTS)
88 rm -f git-subtree
90 override_dh_auto_install-arch:
91 # git
92 DESTDIR='$(GIT)' $(MAKE) install $(OPTS)
93 DESTDIR='$(GIT)' $(MAKE) -C contrib/subtree install $(OPTS)
94 install -d -m0755 '$(GIT)'/var/lib/git
95 rm -rf '$(GIT)'/usr/share/man
96 # don't include arch, cvs, p4, svn, email, gui tools, and gitk program
97 for i in git-archimport git-cvs git-p4 git-svn git-send-email \
98 git-gui git-citool; do \
99 rm -f '$(GIT)'/usr/lib/git-core/$$i*; \
100 done
101 rm -f '$(GIT)'/usr/bin/git-cvsserver
102 rm -f '$(GIT)'/usr/bin/gitk
103 # don't include git-gui's lib
104 rm -rf '$(GIT)'/usr/share/git-gui/
105 # don't include gitk's lib
106 rm -rf '$(GIT)'/usr/share/gitk/
107 # don't include git-svn's lib
108 rm -rf '$(GIT)'/usr/share/perl5/Git/SVN*
109 # sanity check that #642603 fix is still in place
110 test $$(stat -c%h \
111 '$(GIT)'/usr/lib/git-core/git-branch) -le 10
113 override_dh_auto_install-indep:
114 DESTDIR='$(TMP)' $(MAKE) install install-doc $(OPTS)
115 DESTDIR='$(TMP)' $(MAKE) -Ccontrib/mw-to-git install $(OPTS) \
116 INSTLIBDIR=/usr/share/perl5
117 test -z '$(DOCS)' || \
118 $(MAKE) -CDocumentation install-webdoc WEBDOC_DEST='$(TMP)'/html \
119 2>/dev/null
120 test -z '$(DOCS)' || \
121 DESTDIR='$(TMP)' $(MAKE) -Ccontrib/subtree install-doc $(OPTS)
122 install -m 0644 contrib/subtree/git-subtree.txt '$(TMP)'/html
123 # RelNotes are shipped in git
124 rm -rf '$(TMP)'/html/RelNotes
125 # don't include git-p4 man page
126 rm -f '$(TMP)'/html/git-p4.*
128 override_dh_install-arch:
129 dh_install --arch
130 rm -rf '$(GIT)'/usr/share/git-core/contrib/hooks/multimail
132 override_dh_install-indep:
133 dh_install --indep
134 for i in git-archimport git-cvs git-p4 git-svn git-send-email gitk \
135 git-gui git-citool; do \
136 rm -f '$(GIT)'-man/usr/share/man/man1/$$i*; \
137 done
139 override_dh_installdocs-arch:
140 dh_installdocs --arch -X.gitignore
141 # These licenses are replaced with symlinks in git.links.
142 diff -q '$(GIT)'/usr/share/doc/git/contrib/persistent-https/LICENSE /usr/share/common-licenses/Apache-2.0
143 diff -bq '$(GIT)'/usr/share/doc/git/contrib/subtree/COPYING /usr/share/common-licenses/GPL-2
144 rm -rf '$(GIT)'/usr/share/doc/git/contrib/completion
145 rm -rf '$(GIT)'/usr/share/doc/git/contrib/emacs
146 rm -rf '$(GIT)'/usr/share/doc/git/contrib/hooks
147 rm -rf '$(GIT)'/usr/share/doc/git/contrib/mw-to-git
148 rm -f '$(GIT)'/usr/share/doc/git/contrib/subtree/git-subtree.1
149 rm -f '$(GIT)'/usr/share/doc/git/contrib/subtree/git-subtree.html
150 rm -f '$(GIT)'/usr/share/doc/git/contrib/subtree/git-subtree.xml
151 find '$(GIT)'/usr/share/doc/git/ -name .gitattributes | xargs rm -f
152 find '$(GIT)'/usr/share/doc/git/ -name .gitignore | xargs rm -f
154 override_dh_installdocs-indep:
155 dh_installdocs --indep -X.gitignore
157 override_dh_installchangelogs:
158 dh_installchangelogs debian/changelog.upstream
160 override_dh_installinit:
161 dh_installinit -pgit-daemon-sysvinit --name=git-daemon
162 dh_installinit
164 # Skip dh_installemacsen to avoid having to rename
165 # /etc/emacs/site-start.d/50git-core.el to
166 # /etc/emacs/site-start.d/50git-el.el.
167 override_dh_installemacsen:
169 override_dh_compress:
170 dh_compress -X.txt -Xcontrib