debian: xdiff: Do not enable XDL_FAST_HASH by default
[git/debian.git] / debian / git-el.postinst
blob89e7492816e029a74597a89f8e001ab169ef82ab
1 #!/bin/sh
2 set -e
4 #DEBHELPER#
6 test "$1" = configure || exit 0
7 /usr/lib/emacsen-common/emacs-package-install git
9 # Clean up after 1:1.7.4.1-1 through 1:1.7.4.1-3.
10 ! test -L /usr/share/git-core/emacs/emacs ||
11 rm -f /usr/share/git-core/emacs/emacs
12 ! test -L /usr/share/doc/git/contrib/emacs.old ||
13 rm -f /usr/share/doc/git/contrib/emacs.old
15 # Replace the old /usr/share/doc/git/contrib/emacs directory
16 # with a symlink.
17 test -z "$2" &&
18 ! test -L /usr/share/doc/git/contrib/emacs &&
19 test -d /usr/share/doc/git/contrib/emacs || exit 0
21 if ! rmdir /usr/share/doc/git/contrib/emacs; then
22 echo Moving /usr/share/doc/git/contrib/emacs to emacs.old >&2
23 mv -f /usr/share/doc/git/contrib/emacs /usr/share/doc/git/contrib/emacs.old
25 ln -s ../../../git-core/emacs /usr/share/doc/git/contrib/emacs