Initial commit
[gentoo-soor-overlay.git] / x11-libs / libXft / libXft-2.1.12.ebuild
blobfae8df3e4ecc16d035f272c9c5c0cb73acf81f51
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/x11-libs/libXft/libXft-2.1.12.ebuild,v 1.10 2007/07/02 13:36:24 armin76 Exp $
5 # Must be before x-modular eclass is inherited
6 #SNAPSHOT="yes"
8 inherit x-modular flag-o-matic
10 DESCRIPTION="X.Org Xft library"
12 KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
14 IUSE="newspr"
16 RDEPEND="x11-libs/libXrender
17 x11-libs/libX11
18 x11-libs/libXext
19 x11-proto/xproto
20 newspr? ( >=media-libs/freetype-2.3.1 )
21 !newspr? ( media-libs/freetype )
22 >=media-libs/fontconfig-2.2"
23 DEPEND="${RDEPEND}"
25 pkg_setup() {
26 # No such function yet
27 # x-modular_pkg_setup
29 # (#125465) Broken with Bdirect support
30 filter-flags -Wl,-Bdirect
31 filter-ldflags -Bdirect
32 filter-ldflags -Wl,-Bdirect
34 src_unpack() {
35 unpack ${A}
36 cd "${S}"/src
37 if use newspr; then
38 epatch "${FILESDIR}"/${PN}-dont_interfere_with_newspr.patch.bz2 || die
42 pkg_postinst() {
43 elog "DO NOT report bugs to Gentoo's bugzilla"
44 elog "See http://forums.gentoo.org/viewtopic-t-511382.html for support topic on Gentoo forums."