Add nicotine+.
[gentoo-soor-overlay.git] / x11-libs / qt-webkit / qt-webkit-4.4.0_rc1.ebuild
blob5bbf48a18774b8ef35e725a0ca867d1f2ef6d75f
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 inherit qt4-build
7 DESCRIPTION="The Webkit module for the Qt toolkit."
8 HOMEPAGE="http://www.trolltech.com/"
10 LICENSE="|| ( QPL-1.0 GPL-3 GPL-2 )"
11 SLOT="4"
12 KEYWORDS="~amd64 ~x86"
13 IUSE=""
15 DEPEND="~x11-libs/qt-gui-${PV}"
16 RDEPEND="${DEPEND}"
18 QT4_TARGET_DIRECTORIES="src/3rdparty/webkit/WebCore tools/designer/src/plugins/qwebview"
19 QT4_EXTRACT_DIRECTORIES="src/3rdparty/webkit src/3rdparty/sqlite"
20 QCONFIG_ADD="webkit"
21 QCONFIG_DEFINE="QT_WEBKIT"
23 src_compile() {
24 local myconf
25 myconf="${myconf} -webkit"
27 qt4-build_src_compile