Add nicotine+.
[gentoo-soor-overlay.git] / net-p2p / nicotine+ / nicotine+-9999.ebuild
blob915c9b2c6e0047e01ddf2a696cd9d7c4276f0dc4
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI="1"
7 inherit distutils eutils subversion multilib toolchain-funcs
9 DESCRIPTION="A fork of nicotine, a Soulseek client in Python"
10 HOMEPAGE="http://nicotine-plus.sourceforge.net"
11 SRC_URI=""
12 ESVN_REPO_URI="http://nicotine-plus.org/svn/trunk/nicotine+"
13 LICENSE="GPL-3 LGPL-3"
14 SLOT="0"
15 KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
16 IUSE="geoip spell vorbis"
18 RDEPEND="virtual/python
19 dev-python/pygtk:2
20 vorbis? ( >=dev-python/pyvorbis-1.4-r1
21 dev-python/pyogg )
22 geoip? ( dev-python/geoip-python
23 dev-libs/geoip )
24 spell? ( dev-python/sexy-python )
25 !net-p2p/nicotine"
27 DEPEND="${RDEPEND}
28 dev-util/pkgconfig
29 sys-apps/sed"
31 src_unpack() {
32 subversion_fetch
33 cd "${S}"
37 src_install() {
38 distutils_python_version
39 distutils_src_install --install-lib \
40 /usr/$(get_libdir)/python${PYVER}/site-packages