Add gnome-commander.
[gentoo-soor-overlay.git] / app-misc / gnome-commander / gnome-commander-1.2.5.ebuild
blobb86c186f69f4f5a75696f27ef18d9f03905e40bc
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License, v2 or later
3 # $Header:
5 inherit gnome2 flag-o-matic
7 RESTRICT="primaryuri"
9 DESCRIPTION="A full featured, dual-pane file manager for Gnome2"
10 HOMEPAGE="http://www.nongnu.org/gcmd/"
12 SRC_URI="http://ftp.gnome.org/pub/GNOME/sources/${PN}/1.2/${P}.tar.bz2";
14 KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
16 LICENSE="GPL-2"
18 IUSE="doc exif gsf id3 python"
19 SLOT="0"
21 USE_DESC="exif: add support for Exif and IPTC
22 gsf: add support for OLE, OLE2 and ODF
23 id3: add support for ID3, Vorbis, FLAC and APE
24 python: add support for python plugins"
26 RDEPEND=">=x11-libs/gtk+-2.8.0
27 >=dev-libs/glib-2.6.0
28 >=gnome-base/libgnomeui-2.4.0
29 >=gnome-base/libgnome-2.4.0
30 >=gnome-base/gnome-vfs-2.0
31 || (
32 app-admin/gamin
33 app-admin/fam
35 exif? ( >=media-gfx/exiv2-0.14 )
36 gsf? ( >=gnome-extra/libgsf-1.12.0 )
37 id3? ( >=media-libs/taglib-1.4 )
38 python? ( >=dev-lang/python-2.4 )"
40 DEPEND="${RDEPEND}
41 dev-util/intltool
42 dev-util/pkgconfig"
44 DOCS="AUTHORS BUGS ChangeLog NEWS README TODO"
46 pkg_setup() {
47 G2CONF=" ${G2CONF}
48 $(use_with exif exiv2)
49 $(use_with gsf libgsf)
50 $(use_with id3 taglib)
51 $(use_enable python python)"
52 filter-ldflags -Wl,--as-needed