Add 4.4.0_rc1
[gentoo-soor-overlay.git] / x11-libs / qt-test / qt-test-4.4.0_rc1.ebuild
blobf5d843832f4706ffae5300bb23c49ae139835e4b
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 inherit qt4-build
7 DESCRIPTION="The testing framework module for the Qt toolkit."
8 HOMEPAGE="http://www.trolltech.com/"
10 LICENSE="|| ( QPL-1.0 GPL-3 GPL-2 )"
11 SLOT="4"
12 KEYWORDS="~amd64 ~x86"
13 IUSE=""
15 DEPEND="~x11-libs/qt-core-${PV}"
16 RDEPEND="${DEPEND}"
18 QT4_TARGET_DIRECTORIES="src/testlib"
20 src_compile() {
21 local myconf
22 myconf="${myconf} -no-xkb -no-tablet -no-fontconfig -no-xrender -no-xrandr
23 -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
24 -no-nas-sound -no-dbus -iconv -no-cups -no-nis -no-gif -no-libpng
25 -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
26 -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
27 -no-fontconfig -no-glib -no-opengl -no-svg"
29 qt4-build_src_compile