Add 4.4.0_rc1
[gentoo-soor-overlay.git] / x11-libs / qt-sql / qt-sql-4.4.0_rc1.ebuild
blob58b55ec88a3e5efb2bf76dd2a751d1d2d87e0830
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI="1"
6 inherit qt4-build
8 DESCRIPTION="The SQL module for the Qt toolkit."
9 HOMEPAGE="http://www.trolltech.com/"
11 LICENSE="|| ( QPL-1.0 GPL-3 GPL-2 )"
12 SLOT="4"
13 KEYWORDS="~amd64 ~x86"
15 IUSE="firebird mysql odbc postgres +qt3support +sqlite"
17 DEPEND="
18 ~x11-libs/qt-core-${PV}
19 firebird? ( dev-db/firebird )
20 sqlite? ( dev-db/sqlite:3 )
21 mysql? ( virtual/mysql )
22 postgres? ( dev-db/libpq
23 dev-db/postgresql )
24 odbc? ( dev-db/unixODBC )"
25 RDEPEND="${DEPEND}"
27 QT4_TARGET_DIRECTORIES="src/sql src/plugins/sqldrivers"
29 pkg_setup() {
30 if ! (use firebird || use mysql || use odbc || use postgres || use sqlite); then
31 ewarn "You need to enable at least one SQL driver. Enable at least"
32 ewarn "one of these USE flags: \"firebird mysql odbc postgres sqlite\""
33 die "Enable at least one SQL driver."
36 use qt3support && QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK}
37 ~x11-libs/qt-core-${PV} qt3support"
39 qt4-build_pkg_setup
42 src_compile() {
43 local myconf
44 # Don't support sqlite2 anymore
45 myconf="${myconf} -no-sql-sqlite2
46 $(qt_use mysql sql-mysql plugin) $(use mysql && echo "-I/usr/include/mysql -L/usr/$(get_libdir)/mysql ")
47 $(qt_use postgres sql-psql plugin) $(use postgres && echo "-I/usr/include/postgresql/pgsql ")
48 $(qt_use sqlite sql-sqlite plugin) $(qt_use sqlite system-sqlite)
49 $(qt_use odbc sql-odbc plugin)
50 $(qt_use qt3support)"
52 myconf="${myconf} -no-xkb -no-tablet -no-fontconfig -no-xrender -no-xrandr
53 -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
54 -no-nas-sound -no-dbus -iconv -no-cups -no-nis -no-gif -no-libpng
55 -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
56 -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility -no-fontconfig
57 -no-glib -no-opengl -no-svg"
59 qt4-build_src_compile