Add 4.4.0_rc1
[gentoo-soor-overlay.git] / x11-libs / qt-opengl / qt-opengl-4.4.0_rc1.ebuild
blobba45e29ffbf9e860d04bdb0683d98141883db274
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI="1"
6 inherit qt4-build
8 DESCRIPTION="The OpenGL module for the Qt toolkit."
9 HOMEPAGE="http://www.trolltech.com/"
11 LICENSE="|| ( QPL-1.0 GPL-3 GPL-2 )"
12 SLOT="4"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="+qt3support"
16 DEPEND="~x11-libs/qt-gui-${PV}
17 virtual/opengl
18 virtual/glu"
19 RDEPEND="${DEPEND}"
21 QT4_TARGET_DIRECTORIES="src/opengl"
22 QCONFIG_ADD="opengl"
23 QCONFIG_DEFINE="QT_OPENGL"
25 pkg_setup() {
26 use qt3support && QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK}
27 ~x11-libs/qt-core-${PV} qt3support"
28 qt4-build_pkg_setup
31 src_compile() {
32 local myconf
33 myconf="${myconf} -opengl
34 $(qt_use qt3support)"
36 # Not building tools/designer/src/plugins/tools/view3d as it's commented out of the build in the source
37 qt4-build_src_compile