Add 4.4.0_rc1
[gentoo-soor-overlay.git] / x11-libs / qt-dbus / qt-dbus-4.4.0_rc1.ebuild
blob92cd41049e0ab648d8e78d78d3b321adbaa0cf53
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 inherit qt4-build
7 DESCRIPTION="The DBus module for the Qt toolkit."
8 HOMEPAGE="http://www.trolltech.com/"
10 LICENSE="|| ( QPL-1.0 GPL-3 GPL-2 )"
11 SLOT="4"
12 KEYWORDS="~amd64 ~x86"
13 IUSE=""
15 # depend on gui instead of core. There's a GUI based viewer that's built, and since it's a desktop
16 # protocol I don't know if there's value trying to derive it out into a core build
17 # The library itself, however, only depends on core and xml
18 DEPEND="~x11-libs/qt-core-${PV}
19 >=sys-apps/dbus-1.0.2"
20 RDEPEND="${DEPEND}"
22 QT4_TARGET_DIRECTORIES="
23 src/dbus
24 tools/qdbus/qdbus
25 tools/qdbus/qdbusxml2cpp
26 tools/qdbus/qdbuscpp2xml"
27 QCONFIG_ADD="dbus dbus-linked"
28 QCONFIG_DEFINE="QT_DBUS"
30 #FIXME: Check if these are still needed with the header package
31 QT4_EXTRACT_DIRECTORIES="
32 include/Qt/
33 include/QtCore/
34 include/QtDBus/
35 src/corelib/global/
36 src/corelib/io/
37 src/corelib/kernel/
38 src/corelib/thread/
39 src/corelib/tools/
42 src_compile() {
43 local myconf
44 myconf="${myconf} -dbus-linked"
46 qt4-build_src_compile