cvsimport
[fvwm-themes.git] / debian / rules
blob645a8facfe01b8e6896da8cd229d04c04f128f4e
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
5 # Uncomment this to turn on verbose mode.
6 export DH_VERBOSE=1
8 # These are used for cross-compiling and for saving the configure script
9 # from having to guess our platform (since we know it already)
10 DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
11 DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
13 CFLAGS = -Wall -g
15 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
16 CFLAGS += -O0
17 else
18 CFLAGS += -O2
19 endif
20 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
21 INSTALL_PROGRAM += -s
22 endif
24 configure:
25 -test ! -x ./configure && ( aclocal; autoheader; automake --add-missing; autoreconf )
28 config.status: configure
29 dh_testdir
30 # Add here commands to configure the package.
31 ./configure --prefix=/usr --disable-run-updatemenu
34 build: build-stamp
36 build-stamp: config.status
37 dh_testdir
38 # Add here commands to compile the package.
39 $(MAKE)
40 #/usr/bin/docbook-to-man debian/fvwm-themes.sgml > fvwm-themes.1
42 clean:
43 dh_testdir
44 dh_testroot
45 rm -f build-stamp
46 # Add here commands to clean up after the build process.
47 -$(MAKE) distclean
49 ifneq "$(wildcard /usr/share/misc/config.sub)" ""
50 cp -f /usr/share/misc/config.sub config.sub
51 endif
52 ifneq "$(wildcard /usr/share/misc/config.guess)" ""
53 cp -f /usr/share/misc/config.guess config.guess
54 endif
56 dh_clean
58 install: build
59 dh_testdir
60 dh_testroot
61 dh_clean -k
62 dh_installdirs
64 # Add here commands to install the package into debian/fvwm-themes.
65 $(MAKE) prefix=$(CURDIR)/debian/fvwm-themes/usr ROOT_PREFIX=$(CURDIR)/debian/fvwm-themes mandir=$(CURDIR)/debian/fvwm-themes/usr/share/man install
68 # Build architecture-independent files here.
69 binary-indep: build install
70 chmod 0644 $(CURDIR)/debian/fvwm-themes/usr/share/fvwm/themes/cde/background/pattern
73 # We have nothing to do by default.
74 # Build architecture-dependent files here.
76 binary-arch: build install
77 cp -f debian/base-control debian/control
78 cp -f debian/base-changelog debian/changelog
79 dh_testdir
80 dh_testroot
81 dh_installchangelogs ChangeLog
82 dh_installdocs
83 # dh_installexamples
84 dh_install
85 dh_installmenu
86 # dh_installdebconf
87 # dh_installlogrotate
88 # dh_installemacsen
89 # dh_installpam
90 # dh_installmime
91 # dh_installinit
92 # dh_installcron
93 # dh_installinfo
94 dh_installman
95 dh_link
96 dh_strip
97 dh_compress
98 dh_fixperms
99 dh_perl
100 # dh_python
101 # dh_makeshlibs
102 dh_installdeb
103 dh_shlibdeps debian/fvwm-themes/usr/bin/*
104 dh_gencontrol
105 dh_md5sums
106 dh_builddeb
109 binary: binary-indep binary-arch
110 .PHONY: build clean binary-indep binary-arch binary install